190326 BOJ (2178) 미로탐색
2178. 미로탐색
문제
N×M크기의 배열로 표현되는 미로가 있다.
1 | 0 | 1 | 1 | 1 | 1 |
---|---|---|---|---|---|
1 | 0 | 1 | 0 | 1 | 0 |
1 | 0 | 1 | 0 | 1 | 1 |
1 | 1 | 1 | 0 | 1 | 1 |
미로에서 1은 이동할 수 있는 칸을 나타내고, 0은 이동할 수 없는 칸을 나타낸다. 이러한 미로가 주어졌을 때, (1, 1)에서 출발하여 (N, M)의 위치로 이동할 때 지나야 하는 최소의 칸 수를 구하는 프로그램을 작성하시오. 한 칸에서 다른 칸으로 이동할 때, 서로 인접한 칸으로만 이동할 수 있다.
위의 예에서는 15칸을 지나야 (N, M)의 위치로 이동할 수 있다. 칸을 셀 때에는 시작 위치와 도착 위치도 포함한다.
입력
첫째 줄에 두 정수 N, M(2 ≤ N, M ≤ 100)이 주어진다. 다음 N개의 줄에는 M개의 정수로 미로가 주어진다. 각각의 수들은 붙어서 입력으로 주어진다.
출력
첫째 줄에 지나야 하는 최소의 칸 수를 출력한다. 항상 도착위치로 이동할 수 있는 경우만 입력으로 주어진다.
예제 입력 1
4 6
101111
101010
101011
111011
예제 출력 1
15
문제 풀이
- 전형적인 BFS 문제
- ‘최소’ 경로!
- 이 코드가 아주 기초~
- 현재 위치로부터 네방향으로 탐색, 갈 수 있으면 다음 위치부터 또 탐색
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.LinkedList;
import java.util.Queue;
class p{
int y,x,cnt;
public p(int y,int x,int cnt){
this.y=y;
this.x=x;
this.cnt=cnt;
}
}
class Main {
static int N,M,result;
static int[] dy={0,1,0,-1};
static int[] dx={1,0,-1,0};
static boolean[][] visited;
static boolean[][] map;
static int[][] res;
public static void bfs(int y,int x){
Queue<p> q=new LinkedList<>();
visited[y][x]=true;
q.offer(new p(y,x,1));
while(!q.isEmpty()) {
p cur=q.poll();
if(cur.y==N-1 && cur.x==M-1) {
result=cur.cnt;
break;
}
for (int i = 0; i < 4; i++) {
int ny = cur.y + dy[i];
int nx = cur.x + dx[i];
if (ny < 0 || nx < 0 || ny >= N || nx >= M) {
continue;
}
if (!visited[ny][nx] && map[ny][nx]) {
visited[ny][nx]=true;
q.offer(new p(ny,nx,cur.cnt+1));
}
}
}
}
public static void main(String[] args) throws IOException {
BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
String[] tmp=br.readLine().split(" ");
N=Integer.parseInt(tmp[0]);
M=Integer.parseInt(tmp[1]);
map=new boolean[N][M];
visited=new boolean[N][M];
res=new int[N][M];
for(int i=0;i<N;i++){
String[] tmp1=br.readLine().split("");
for(int j=0;j<M;j++){
if(Integer.parseInt(tmp1[j])==1)
map[i][j]=true;
else
map[i][j]=false;
}
}
bfs(0,0);
System.out.println(result);
}
}